Language Selection

English French German Italian Portuguese Spanish

Ubuntu-Based Voyager 20.10 GE Released With Linux 5.8

Filed under
Linux
Ubuntu

After the release of Ubuntu 20.10 “Groovy Gorilla” last month, other Linux distributions built on top of Ubuntu also started announcing their own updated versions based on Ubuntu 20.10 like Pop!_OS 20.10.

Along the same line, here comes yet another Ubuntu Groovy Gorilla-based distro, Voyager 20.10 GE, featuring Linux Kernel 5.8 and GNOME 3.38 desktop environment. Let’s see what Voyager 20.10 has to offer...

Read more

More in Tux Machines

Installing Debian on modern hardware

It is an unfortunate fact of life that non-free firmware blobs are required to use some hardware, such as network devices (WiFi in particular), audio peripherals, and video cards. Beyond that, those blobs may even be required in order to install a Linux distribution, so an installation over the network may need to get non-free firmware directly from the installation media. That, as might be guessed, is a bit of a problem for distributions that are not willing to officially ship said firmware because of its non-free status, as a recent discussion in the Debian community shows. Surely Dan Pal did not expect the torrent of responses he received to his short note to the debian-devel mailing list about problems he encountered trying to install Debian. He wanted to install the distribution on a laptop that was running Windows 10, but could not use the normal network installation mechanism because the WiFi device required non-free firmware. He tracked down the DVD version of the distribution and installed that, but worried that Debian is shooting itself in the foot by not prominently offering more installation options: "The current policy of hiding other versions of Debian is limiting the adoption of your OS by people like me who are interested in moving from Windows 10." The front page at debian.org currently has a prominent "Download" button that starts to retrieve a network install ("netinst") CD image when clicked. But that image will not be terribly useful for systems that need non-free firmware to make the network adapter work. Worse yet, it is "impossible to find" a working netinst image with non-free firmware, Sven Joachim said, though he was overstating things a bit. Alexis Murzeau suggested adding a link under the big download button that would lead users to alternate images containing non-free firmware. He also pointed out that there are two open bugs (one from 2010 and another from 2016) that are related, so the problem is hardly a new one. Read more

Wayland 1.19 Released With Small Protocol Updates, Fixes

Wayland 1.18 released back in February 2020 while now nearly one year later it's been succeeded by Wayland 1.19. Even with one year passing, Wayland 1.19 is a very minor update over Wayland 1.18. That's part of the reason why they moved off timed releases in the first place was the core Wayland code and protocol being quite stable at this point: there is very little change. Most of the work remaining to get Wayland ready for production use across all workloads is on the compositor side with KDE Plasma's KWin seeing improvements, GNOME Shell + Mutter being in very good shape, etc. There is also the driver obstacle of the NVIDIA proprietary driver support at the moment not being ideal but improvements are pending there. That is all outside of the core Wayland code itself that is the protocol and key libraries. Read more

Android Leftovers

Stable Kernels: 5.10.11, 5.4.93, and 4.19.171

I'm announcing the release of the 5.10.11 kernel.

All users of the 5.10 kernel series must upgrade.

The updated 5.10.y git tree can be found at:
	git://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git linux-5.10.y
and can be browsed at the normal kernel.org git web browser:
	https://git.kernel.org/?p=linux/kernel/git/stable/linux-s...

thanks,

greg k-h
Read more Also: Linux 5.4.93 Linux 4.19.171